关注各种黑科技
B站UP主,编程教学,游戏玩家,挂B,金牛座

python xxx whl is not a supported wheel on this platform

群里有个同学在安装gevent时遇到如下错误 xxx whl is not a supported wheel on this platform 原因是gevent的新版本不提供exe包了, https://pypi.python.org/pypi/gevent/1.2.0 历史版本查看方法 https://pypi.python.org/pypi/gevent/json 解决方法 升级pip

pip install -U pip   如果报错 再执行一遍命令

pip install gevent-1.2.0-cp27-cp27m-win32.whl   如果报错 再执行一遍命令

上面命令不知道为什么会报错 如果不放心还是直接pip从网络下载并且编译安装吧

编译需要vc编译器 vcvarsall.bat

https://www.microsoft.com/en-us/download/details.aspx?id=44266 参考 http://stackoverflow.com/questions/28568070/filename-whl-is-not-supported-wheel-on-this-platform http://stackoverflow.com/questions/2817869/error-unable-to-find-vcvarsall-bat
转载请注明出处
分享到: 更多 (0)

评论 1